install of v0.85 failed in a .NET 3.5 targeted project

Sep 6, 2011 at 5:46 PM

I am adding some MVC into an existing web app that targets .NET 3.5. When I install Glimpse via nuget I get this error:

PM> Install-Package Glimpse

Successfully installed 'Glimpse 0.85'.

Successfully uninstalled 'Glimpse 0.85'.

Install failed. Rolling back...

Install-Package : Unable to find assembly references that are compatible with the target framework '.NETFramework,Version=v3.5'.

At line:1 char:16

+ Install-Package <<<< Glimpse

+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException

+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

So what should I do next? I don't really want to upgrade the project to 4.0 just to use Glimpse. Got the same error for Glimpse.MVC3.